AWS US-East outage

Incident Report for Foxpass

Resolved

All subsidiary systems affected by the AWS US-East-1 outage appear to be back to normal.
Posted Oct 20, 2025 - 16:54 PDT

Identified

We are monitoring issues related to the major outage affecting Amazon Web Services (AWS) US-East-1 region. Foxpass RADIUS and LDAP core services are unaffected, but our support tool hosted on Intercom and console global lookup are experiencing intermittent degradation.
Posted Oct 20, 2025 - 10:15 PDT
This incident affected: AWS rds-us-east-1 and AWS ec2-us-east-1.